Delayed Transactions - Polygon
Incident Report for Coinbase Pro
Resolved
This incident has been resolved.
Posted Nov 15, 2023 - 16:04 PST
Investigating
Sends are delayed for Polygon. While we work on a fix, your funds remain secure.
Posted Nov 15, 2023 - 08:13 PST