Delayed Transactions (Osmosis)
Incident Report for Coinbase Pro
Resolved
This incident has been resolved.
Posted Dec 15, 2023 - 17:25 PST
Investigating
Sends are delayed for Osmosis (OSMO). While we work on a fix, your funds remain secure.
Posted Dec 15, 2023 - 15:30 PST