Delayed transactions - Algorand
Incident Report for Coinbase Pro
Resolved
This incident has been resolved.
Posted Jan 12, 2024 - 13:48 PST
Investigating
We are aware that some users may be experiencing delayed sends/receives on Algorand (ALGO). While we work on a fix, your funds remain secure.
Posted Jan 09, 2024 - 10:00 PST