Delayed Transactions ARB
Incident Report for Coinbase Pro
Resolved
This incident has been resolved.
Posted Nov 20, 2023 - 12:08 PST
Investigating
Sends are delayed for Arbitrum (ARB). While we work on a fix, your funds remain secure.
Posted Nov 16, 2023 - 13:29 PST