Delayed Transactions (ARB)
Incident Report for Coinbase Pro
Resolved
This incident has been resolved.
Posted Nov 14, 2023 - 21:15 PST
Investigating
Sends are delayed for Arbitrum (ARB). While we work on a fix, your funds remain secure.
Posted Nov 14, 2023 - 20:25 PST